NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
CRITICAL severity

RubyGems vulnerable to Deserialization of Untrusted DataGHSA-mqwr-4qf2-2hcv

CRITICALFix: rubygems/rubygems@510b163

GHSA-mqwr-4qf2-2hcv is a critical-severity (CVSS 9.8) Deserialization of Untrusted Data vulnerability in rubygems-update. EPSS puts its 30-day exploitation probability at 15.9% (97th percentile). A fix is available for rubygems-update — see the affected versions and patch details below.

Also known asCVE-2017-0903
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
15.9%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs97th percentile — riskier than 97% of all scored CVEsHighest risk
2.45%7.95%13.4%18.9%5.5%15.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎rubygems-update

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

RubyGems versions between 2.0.0 and 2.6.13 are vulnerable to a possible remote code execution vulnerability. YAML deserialization of gem specifications can bypass class white lists. Specially crafted serialized objects can possibly be used to escalate to remote code execution. The issue has been patched in 2.6.14.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsrubygems-update≥ 2.0.0&&< 2.6.142.6.14bundle update rubygems-update --conservative

Affected Products

9 products · 87 configurations
OS
ubuntu linuxcanonical
3 versions
14.0416.0417.10
OS
debian linuxdebian
2 versions
8.09.0
OS
enterprise linux desktopredhat
1 version
7.0
OS
enterprise linux serverredhat
1 version
7.0
OS
enterprise linux server ausredhat
2 versions
7.47.6
OS
enterprise linux server eusredhat
3 versions
7.47.57.6

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for rubygems-update, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update rubygems-update to 2.6.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-mqwr-4qf2-2hcv is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

This issue did not affect the versions of rubygems as shipped with Red Hat Enterprise Linux 6. This issue affects the versions of ruby as shipped with Red Hat Enterprise Linux 7 and the versions of rh-ruby22-ruby and rh-ruby23-ruby as shipped with Red Hat Software Collections. Red Hat Product Security has rated this…

ProductFixed inAdvisory
Red Hat Enterprise Linux 7ruby-0:2.0.0.648-33.el7_4RHSA-2018:0378
Red Hat Software Collections for Red Hat Enterprise Linux 6rh-ruby24-ruby-0:2.4.2-86.el6RHSA-2017:3485
Red Hat Software Collections for Red Hat Enterprise Linux 6rh-ruby22-ruby-0:2.2.9-19.el6RHSA-2018:0583
Red Hat Software Collections for Red Hat Enterprise Linux 6rh-ruby23-ruby-0:2.3.6-67.el6RHSA-2018:0585

Frequently Asked Questions

RubyGems versions between 2.0.0 and 2.6.13 are vulnerable to a possible remote code execution vulnerability. YAML deserialization of gem specifications can bypass class white lists. Specially crafted serialized objects can possibly be used to escalate to remote code execution. The issue has been patched in 2.6.14.
O3 Security · Impact-Aware SCA

Is GHSA-mqwr-4qf2-2hcv in your dependencies?

Find it across RubyGems, including transitive dependencies.

RubyGems vulnerable to Deserialization of Untrusted Data