Stored XSS in Miniflux when opening a broken image due to unescaped ServerError in proxy handlerGHSA-mqqg-xjhj-wfgw
MEDIUMFix: miniflux/v2#1746GHSA-mqqg-xjhj-wfgw is a medium-severity (CVSS 4.8) Cross-site Scripting (XSS) vulnerability in miniflux.app/v2. A fix is available for miniflux.app/v2 — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-mqqg-xjhj-wfgw.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
miniflux.app/v2Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Since v2.0.25, Miniflux will automatically proxy images served over HTTP to prevent mixed content errors.
When an outbound request made by the Go HTTP client fails, the html.ServerError is returned unescaped without the expected Content Security Policy header added to valid responses.
By creating an RSS feed item with the inline description containing an <img> tag with a srcset attribute pointing to an invalid URL like http:a<script>alert(1)</script>, we can coerce the proxy handler into an error condition where the invalid URL is returned unescaped and in full.
This results in JavaScript execution on the Miniflux instance as soon as the user is convinced (e.g. by a message in the alt text) to open the broken image.
An attacker can execute arbitrary JavaScript in the context of a victim Miniflux user when they open a broken image in a crafted RSS feed. This can be used to perform actions on the Miniflux instance as that user and gain administrative access to the Miniflux instance if it is reachable and the victim is an administrator.
Patches
PR #1746 fixes the problem. Available in Miniflux >= 2.0.43.
Workarounds
- Disable image proxy (default value is
http-only).
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | miniflux.app/v2 | ≥ 2.0.25&&< 2.0.43 | 2.0.43go get miniflux.app/v2@v2.0.43 |
Affected Products
minifluxminiflux_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for miniflux.app/v2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update miniflux.app/v2 to 2.0.43 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-mqqg-xjhj-wfgw is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-mqqg-xjhj-wfgw in your dependencies?
Find it across Go, including transitive dependencies.