Your RSA-2048 keys break in 2030. Find every one of them before attackers do.
☕
☕ Maven📦 npm.NET NuGet💎 RubyGems
Not in CISA KEV
HIGH severity

Denial of Service in jqueryGHSA-mhpp-875w-9cpv

HIGHFix: jquery/jquery#3134

GHSA-mhpp-875w-9cpv is a high-severity (CVSS 7.5) CWE-674 vulnerability in org.webjars.npm:jquery. 1 public exploit reference exists, so weaponization risk is real. A fix is available for org.webjars.npm:jquery — see the affected versions and patch details below.

Also known asCVE-2016-10707
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
1 known
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.2%probability of exploitation in next 30 days
Lower Risk+0.35%
Lower risk than most CVEs88th percentile — riskier than 88% of all scored CVEsHighest risk
0.00%1.35%2.69%4.04%0.9%3.2%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

GHSA-mhpp-875w-9cpv by exploitation likelihood (EPSS) against impact (CVSS). Outside the shaded patch-first corner.

Where this sits among everything scored

Of 397,508 CVEs with a current EPSS score, this one falls in the < 10% band (highlighted). Counts from FIRST.org, log-scaled.

Real-World Exposure

4 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

22Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
jquerynpm
11.7Mdownloads / week

Description

Affected versions of jquery use a lowercasing logic on attribute names. When given a boolean attribute with a name that contains uppercase characters, jquery enters into an infinite recursion loop, exceeding the call stack limit, and resulting in a denial of service condition.

Recommendation

Update to version 3.0.0 or later.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.webjars.npm:jquery≥ 3.0.0-rc1&&< 3.0.03.0.0org.webjars.npm:jquery:3.0.0
📦npmjquery≥ 3.0.0-rc.1&&< 3.0.03.0.0npm install jquery@3.0.0
.NETNuGetjQuery≥ 3.0.0-rc.1&&< 3.0.03.0.0dotnet add package jQuery --version 3.0.0
💎RubyGemsjquery-rails≥ 3.0.0-rc.1&&< 3.0.03.0.0bundle update jquery-rails --conservative

Affected Products

1 product · 1 configurations
Application
jqueryjquery
1 version
3.0.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.webjars.npm:jquery, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.webjars.npm:jquery to 3.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-mhpp-875w-9cpv is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

Affected versions of `jquery` use a lowercasing logic on attribute names. When given a boolean attribute with a name that contains uppercase characters, `jquery` enters into an infinite recursion loop, exceeding the call stack limit, and resulting in a denial of service condition. ## Recommendation Update to version 3.0.0 or later.
O3 Security · Impact-Aware SCA

Is GHSA-mhpp-875w-9cpv in your dependencies?

Find it across Maven, npm, NuGet, including transitive dependencies.

Denial of Service in jquery (High 7.5)