NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

PySAML2 XML external entity attackGHSA-m269-wj6g-c459

CRITICALFix: rohe/pysaml2#379

GHSA-m269-wj6g-c459 is a critical-severity (CVSS 9) XML External Entity (XXE) vulnerability in pysaml2. A fix is available for pysaml2 — see the affected versions and patch details below.

Also known asCVE-2016-10127PYSEC-2017-67
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs85th percentile — riskier than 85% of all scored CVEsHighest risk
0.00%1.09%2.17%3.26%0.5%2.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍pysaml2

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

PySAML2 allows remote attackers to conduct XML external entity (XXE) attacks via a crafted SAML XML request or response.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIpysaml2all versions4.5.0pip install --upgrade 'pysaml2==4.5.0'

Affected Products

1 product · 1 configurations
Application
pysaml2pysaml2_project
all

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pysaml2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update pysaml2 to 4.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-m269-wj6g-c459 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

PySAML2 allows remote attackers to conduct XML external entity (XXE) attacks via a crafted SAML XML request or response.
O3 Security · Impact-Aware SCA

Is GHSA-m269-wj6g-c459 in your dependencies?

Find it across PyPI, including transitive dependencies.

PySAML2 XML external entity attack (Critical 9)