NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2016-10149 — pysaml2

HIGHFix: rohe/pysaml2@6e09a25

CVE-2016-10149 is a high-severity (CVSS 7.5) XML External Entity (XXE) vulnerability in pysaml2. A fix is available for pysaml2 — see the affected versions and patch details below.

Pysaml2 does not sanitize XML responses

Also known asGHSA-c2vx-49jm-h3f6PYSEC-2017-25
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
5.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
0.00%2.08%4.16%6.24%1.3%5.0%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍pysaml2

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

XML External Entity (XXE) vulnerability in PySAML2 4.4.0 and earlier allows remote attackers to read arbitrary files via a crafted SAML XML request or response.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIpysaml2all versions4.5.0pip install --upgrade 'pysaml2==4.5.0'

Affected Products

2 products · 2 configurations
OS
debian linuxdebian
1 version
8.0
Application
pysaml2pysaml2_project
≤ 4.4.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pysaml2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update pysaml2 to 4.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-10149 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat OpenStack Platform 10.0 (Newton)python-defusedxml-0:0.5.0-1.el7ostRHSA-2017:0938
Red Hat OpenStack Platform 8.0 (Liberty)python-defusedxml-0:0.5.0-1.el7ostRHSA-2017:0936
Red Hat OpenStack Platform 9.0 (Mitaka)python-defusedxml-0:0.5.0-1.el7ostRHSA-2017:0937

Frequently Asked Questions

XML External Entity (XXE) vulnerability in PySAML2 4.4.0 and earlier allows remote attackers to read arbitrary files via a crafted SAML XML request or response.
O3 Security · Impact-Aware SCA

Is CVE-2016-10149 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2016-10149: pysaml2 XXE — Fixed in 4.5.0