NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2020-5390 — pysaml2

HIGHFix: IdentityPython/pysaml2@5e9d5ac

CVE-2020-5390 is a high-severity (CVSS 7.5) CWE-347 vulnerability in pysaml2. A fix is available for pysaml2 — see the affected versions and patch details below.

Improper Verification of Cryptographic Signature in PySAML2

Also known asGHSA-qf7v-8hj3-4xw7PYSEC-2020-94
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs69th percentile — riskier than 69% of all scored CVEsHighest risk
0.26%0.75%1.24%1.73%0.8%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍pysaml2

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

PySAML2 before 5.0.0 does not check that the signature in a SAML document is enveloped and thus signature wrapping is effective, i.e., it is affected by XML Signature Wrapping (XSW). The signature information and the node/object that is signed can be in different places and thus the signature verification will succeed, but the wrong data will be used. This specifically affects the verification of assertion that have been signed.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIpysaml2all versions5.0.0pip install --upgrade 'pysaml2==5.0.0'

Affected Products

3 products · 8 configurations
OS
ubuntu linuxcanonical
4 versions
16.0418.0419.0419.10
OS
debian linuxdebian
3 versions
8.09.010.0
Application
pysaml2pysaml2_project
< 5.0.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pysaml2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update pysaml2 to 5.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-5390 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

All versions of Red Hat OpenStack Platform ship but do not use the flawed check-signature functionality of python-pysaml2. The impact for these products is therefore rated as having a security impact of Low and no update will be provided at this time for the impacted RHOSP packages.

Workaround published by Red Hat
There is no known mitigation for this issue, the flaw can only be resolved by applying updates.
Source: Red Hat security advisory for CVE-2020-5390 (CC BY 4.0)

Frequently Asked Questions

PySAML2 before 5.0.0 does not check that the signature in a SAML document is enveloped and thus signature wrapping is effective, i.e., it is affected by XML Signature Wrapping (XSW). The signature information and the node/object that is signed can be in different places and thus the signature verification will succeed, but the wrong data will be used. This specifically affects the verification of assertion that have been signed.
O3 Security · Impact-Aware SCA

Is CVE-2020-5390 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2020-5390: pysaml2 — Fixed in 5.0.0