CVE-2017-1000433 is a high-severity (CVSS 8.1) Improper Authentication vulnerability in pysaml2. A fix is available for pysaml2 — see the affected versions and patch details below.
pysaml2 Improper Authentication vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
pysaml2Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
pysaml2 version 4.4.0 and older accept any password when run with python optimizations enabled. This allows attackers to log in as any user without knowing their password.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | pysaml2 | all versions | 4.5.0pip install --upgrade 'pysaml2==4.5.0' |
Affected Products
debian linuxdebianpysaml2pysaml2_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pysaml2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update pysaml2 to 4.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-1000433 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2017-1000433 in your dependencies?
Find it across PyPI, including transitive dependencies.