SAML authentication bypass via Incorrect XPath selectorGHSA-jw9c-mfg7-9rx2
CRITICALFix: SAML-Toolkits/ruby-saml@1ec5392GHSA-jw9c-mfg7-9rx2 is a critical-severity (CVSS 10) CWE-347 vulnerability in ruby-saml. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for ruby-saml — see the affected versions and patch details below.
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for GHSA-jw9c-mfg7-9rx2.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ruby-saml💎ruby-samlReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
The Ruby SAML library is for implementing the client side of a SAML authorization. Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed saml document (by the IdP) can thus forge a SAML Response/Assertion with arbitrary contents. This would allow the attacker to log in as arbitrary user within the vulnerable system. This vulnerability is fixed in 1.17.0 and 1.12.3.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | ruby-saml | all versions | 1.12.3bundle update ruby-saml --conservative |
| 💎RubyGems | ruby-saml | ≥ 1.13.0&&< 1.17.0 | 1.17.0bundle update ruby-saml --conservative |
Affected Products
gitlabgitlabomniauth samlomniauthruby-samloneloginResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ruby-saml, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ruby-saml to 1.12.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-jw9c-mfg7-9rx2 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-jw9c-mfg7-9rx2 in your dependencies?
Find it across RubyGems, including transitive dependencies.