CVE-2025-25291 — ruby-saml
Fix: SAML-Toolkits/ruby-saml@e76c5b3CVE-2025-25291 is a CWE-347 vulnerability in ruby-saml. EPSS puts its 30-day exploitation probability at 21.0% (98th percentile). A fix is available for ruby-saml — see the affected versions and patch details below.
ruby-saml vulnerable to SAML authentication bypass due to DOCTYPE handling (parser differential)
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-25291.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
ruby-saml💎ruby-samlReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
ruby-saml provides security assertion markup language (SAML) single sign-on (SSO) for Ruby. An authentication bypass vulnerability was found in ruby-saml prior to versions 1.12.4 and 1.18.0 due to a parser differential. ReXML and Nokogiri parse XML differently; the parsers can generate entirely different document structures from the same XML input. That allows an attacker to be able to execute a Signature Wrapping attack. This issue may lead to authentication bypass. Versions 1.12.4 and 1.18.0 fix the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | ruby-saml | all versions | 1.12.4bundle update ruby-saml --conservative |
| 💎RubyGems | ruby-saml | ≥ 1.13.0&&< 1.18.0 | 1.18.0bundle update ruby-saml --conservative |
Affected Products
storagegridnetappomniauth samlomniauthruby-samloneloginDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ruby-saml, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ruby-saml to 1.12.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-25291 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Frequently Asked Questions
Is CVE-2025-25291 in your dependencies?
Find it across RubyGems, including transitive dependencies.