NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
CRITICAL severity

Ruby SAML allows a SAML authentication bypass due to DOCTYPE handling (parser differential)GHSA-4vc4-m8qh-g8jm

CRITICALFix: SAML-Toolkits/ruby-saml@e76c5b3

GHSA-4vc4-m8qh-g8jm is a critical-severity (CVSS 9.8) CWE-347 vulnerability in ruby-saml. EPSS puts its 30-day exploitation probability at 21.0% (98th percentile). A fix is available for ruby-saml — see the affected versions and patch details below.

Also known asBIT-gitlab-2025-25291CVE-2025-25291
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for GHSA-4vc4-m8qh-g8jm.

EPSS Exploitation Probability

via FIRST.org ↗
21.0%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs98th percentile — riskier than 98% of all scored CVEsHighest risk
19.0%19.8%20.6%21.5%20.8%21.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
💎ruby-saml💎ruby-saml

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

ruby-saml provides security assertion markup language (SAML) single sign-on (SSO) for Ruby. An authentication bypass vulnerability was found in ruby-saml prior to versions 1.12.4 and 1.18.0 due to a parser differential. ReXML and Nokogiri parse XML differently; the parsers can generate entirely different document structures from the same XML input. That allows an attacker to be able to execute a Signature Wrapping attack. This issue may lead to authentication bypass. Versions 1.12.4 and 1.18.0 fix the issue.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsruby-samlall versions1.12.4bundle update ruby-saml --conservative
💎RubyGemsruby-saml≥ 1.13.0&&< 1.18.01.18.0bundle update ruby-saml --conservative

Affected Products

3 products · 6 configurations
Application
storagegridnetapp
all
Application
omniauth samlomniauth
≥ 2.2.0 && < 2.2.3
range
Application
ruby-samlonelogin
≥ 1.13.0 && < 1.18.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ruby-saml, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ruby-saml to 1.12.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-4vc4-m8qh-g8jm is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

### Summary An authentication bypass vulnerability was found in ruby-saml due to a parser differential. ReXML and Nokogiri parse XML differently, the parsers can generate entirely different document structures from the same XML input. That allows an attacker to be able to execute a Signature Wrapping attack. ### Impact This issue may lead to authentication bypass.
O3 Security · Impact-Aware SCA

Is GHSA-4vc4-m8qh-g8jm in your dependencies?

Find it across RubyGems, including transitive dependencies.

Ruby SAML allows a SAML authentication bypass due to…