NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
CRITICAL severity

CVE-2024-45409 — ruby-saml

CRITICALFix: SAML-Toolkits/ruby-saml@1ec5392

CVE-2024-45409 is a critical-severity (CVSS 10) CWE-347 vulnerability in ruby-saml. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for ruby-saml — see the affected versions and patch details below.

The Ruby SAML library vulnerable to a SAML authentication bypass via Incorrect XPath selector

Also known asBIT-gitlab-2024-45409GHSA-jw9c-mfg7-9rx2
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
2 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-45409.

EPSS Exploitation Probability

via FIRST.org ↗
10.7%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs96th percentile — riskier than 96% of all scored CVEsHighest risk
0.50%18.6%36.7%54.8%42.4%10.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
💎ruby-saml💎ruby-saml

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

The Ruby SAML library is for implementing the client side of a SAML authorization. Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed saml document (by the IdP) can thus forge a SAML Response/Assertion with arbitrary contents. This would allow the attacker to log in as arbitrary user within the vulnerable system. This vulnerability is fixed in 1.17.0 and 1.12.3.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsruby-samlall versions1.12.3bundle update ruby-saml --conservative
💎RubyGemsruby-saml≥ 1.13.0&&< 1.17.01.17.0bundle update ruby-saml --conservative

Affected Products

3 products · 10 configurations
Application
gitlabgitlab
≥ 17.3.0 && < 17.3.3
range
Application
omniauth samlomniauth
≤ 1.10.3
2 versions
2.0.02.1.0
Application
ruby-samlonelogin
≥ 1.13.0 && < 1.17.0
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ruby-saml, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ruby-saml to 1.12.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-45409 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The Ruby SAML library is for implementing the client side of a SAML authorization. Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed saml document (by the IdP) can thus forge a SAML Response/Assertion with arbitrary contents. This would allow the attacker to log in as arbitrary user within the vulnerable system. This vulnerability is fixed in 1.17.0 and 1.12.3.
O3 Security · Impact-Aware SCA

Is CVE-2024-45409 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2024-45409: ruby-saml — Fixed in 1.12.3