NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

Divide By Zero in OpenCVGHSA-hxfw-jm98-v4mq

MEDIUMFix: opencv/opencv#15382

GHSA-hxfw-jm98-v4mq is a medium-severity (CVSS 5.9) CWE-369 vulnerability in opencv-python. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for opencv-python — see the affected versions and patch details below.

Also known asCVE-2019-15939PYSEC-2026-2799PYSEC-2026-2822PYSEC-2026-2838PYSEC-2026-722
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs84th percentile — riskier than 84% of all scored CVEsHighest risk
0.20%1.13%2.05%2.98%0.7%2.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐍opencv-python🐍opencv-python-headless🐍opencv-contrib-python🐍opencv-contrib-python-headless

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in OpenCV 4.1.0 (OpenCV-Python 4.1.0.25). There is a divide-by-zero error in cv::HOGDescriptor::getDescriptorSize in modules/objdetect/src/hog.cpp.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIopencv-pythonall versions4.1.1.26pip install --upgrade 'opencv-python==4.1.1.26'
🐍PyPIopencv-python-headlessall versions4.1.1.26pip install --upgrade 'opencv-python-headless==4.1.1.26'
🐍PyPIopencv-contrib-pythonall versions4.1.1.26pip install --upgrade 'opencv-contrib-python==4.1.1.26'
🐍PyPIopencv-contrib-python-headlessall versions4.1.1.26pip install --upgrade 'opencv-contrib-python-headless==4.1.1.26'

Affected Products

3 products · 3 configurations
OS
debian linuxdebian
1 version
9.0
Application
opencvopencv
≤ 4.1.0
range
OS
leapopensuse
1 version
15.1
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for opencv-python, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update opencv-python to 4.1.1.26 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-hxfw-jm98-v4mq is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
Workaround published by Red Hat
Avoid using the Histogram of Oriented Gradients (HOG) Descriptor algorithm to detect objects in digital images. Alternatively, ensure HOGDescriptor objects are not created from external untrusted files.
Source: Red Hat security advisory for GHSA-hxfw-jm98-v4mq (CC BY 4.0)

Frequently Asked Questions

An issue was discovered in OpenCV 4.1.0 (OpenCV-Python 4.1.0.25). There is a divide-by-zero error in cv::HOGDescriptor::getDescriptorSize in modules/objdetect/src/hog.cpp.
O3 Security · Impact-Aware SCA

Is GHSA-hxfw-jm98-v4mq in your dependencies?

Find it across PyPI, including transitive dependencies.

Divide By Zero in OpenCV (Medium 5.9)