GHSA-hwmh-9jj9-8c9c is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in contao/contao. A fix is available for contao/contao — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
contao/contao🐘contao/core-bundleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Security researcher Ali Razzaq has discovered that the request token check can be bypassed in Contao 4.7
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | contao/contao | ≥ 4.7.0&&< 4.7.3 | 4.7.3composer require contao/contao:^4.7.3 |
| 🐘Packagist | contao/core-bundle | ≥ 4.7.0&&< 4.7.3 | 4.7.3composer require contao/core-bundle:^4.7.3 |
Affected Products
contao cmscontaoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for contao/contao, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update contao/contao to 4.7.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-hwmh-9jj9-8c9c is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-hwmh-9jj9-8c9c in your dependencies?
Find it across Packagist, including transitive dependencies.