NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
HIGH severity

WEBRick vulnerable to HTTP Request/Response SmugglingGHSA-gwfg-cqmg-cf8f

HIGHFix: ruby/webrick@076ac63

GHSA-gwfg-cqmg-cf8f is a high-severity (CVSS 7.5) CWE-444 vulnerability in webrick. A fix is available for webrick — see the affected versions and patch details below.

Also known asBIT-ruby-2020-25613BIT-ruby-min-2020-25613CVE-2020-25613
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs90th percentile — riskier than 90% of all scored CVEsHighest risk
0.00%1.64%3.28%4.92%0.3%3.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
💎webrick💎webrick💎webrick

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in Ruby through 2.5.8, 2.6.x through 2.6.6, and 2.7.x through 2.7.1. WEBrick, a simple HTTP server bundled with Ruby, had not checked the transfer-encoding header value rigorously. An attacker may potentially exploit this issue to bypass a reverse proxy (which also has a poor header check), which may lead to an HTTP Request Smuggling attack.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemswebrick≥ 1.6.0&&< 1.6.11.6.1bundle update webrick --conservative
💎RubyGemswebrick≥ 1.5.0&&< 1.5.11.5.1bundle update webrick --conservative
💎RubyGemswebrickall versions1.4.4bundle update webrick --conservative

Affected Products

3 products · 6 configurations
OS
fedorafedoraproject
2 versions
3233
Application
rubyruby-lang
≥ 2.7.0 && ≤ 2.7.1
range
Application
webrickruby-lang
≤ 1.6.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for webrick, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update webrick to 1.6.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-gwfg-cqmg-cf8f is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Enterprise Linux 8ruby:2.7-8040020210421133318.522a0ee4RHSA-2021:2584
Red Hat Enterprise Linux 8ruby:2.5-8040020200923213910.522a0ee4RHSA-2021:2587
Red Hat Enterprise Linux 8ruby:2.6-8040020210430142949.522a0ee4RHSA-2021:2588
Red Hat Enterprise Linux 8.1 Update Services for SAP Solutionsruby:2.6-8010020220201152941.c27ad7f8RHSA-2022:0581
Red Hat Enterprise Linux 8.2 Extended Update Supportruby:2.6-8020020220201131207.4cda2c84RHSA-2022:0582
Red Hat Software Collections for Red Hat Enterprise Linux 7rh-ruby25-ruby-0:2.5.9-9.el7RHSA-2021:2104
Red Hat Software Collections for Red Hat Enterprise Linux 7rh-ruby27-ruby-0:2.7.3-129.el7RHSA-2021:2229
Red Hat Software Collections for Red Hat Enterprise Linux 7rh-ruby26-ruby-0:2.6.7-119.el7RHSA-2021:2230

Frequently Asked Questions

An issue was discovered in Ruby through 2.5.8, 2.6.x through 2.6.6, and 2.7.x through 2.7.1. WEBrick, a simple HTTP server bundled with Ruby, had not checked the transfer-encoding header value rigorously. An attacker may potentially exploit this issue to bypass a reverse proxy (which also has a poor header check), which may lead to an HTTP Request Smuggling attack.
O3 Security · Impact-Aware SCA

Is GHSA-gwfg-cqmg-cf8f in your dependencies?

Find it across RubyGems, including transitive dependencies.

WEBRick vulnerable to HTTP Request/Response Smuggling