NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎 RubyGems
Not in CISA KEV

CVE-2009-4492 — webrick

CVE-2009-4492 is a security vulnerability in webrick. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for webrick — see the affected versions and patch details below.

WEBrick Improper Input Validation vulnerability

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
4 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
16.2%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs97th percentile — riskier than 97% of all scored CVEsHighest risk
15.1%16.2%17.2%18.3%17.7%16.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
💎webrick

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

WEBrick 1.3.1 in Ruby 1.8.6 through patchlevel 383, 1.8.7 through patchlevel 248, 1.8.8dev, 1.9.1 through patchlevel 376, and 1.9.2dev writes data to a log file without sanitizing non-printable characters, which might allow remote attackers to modify a window's title, or possibly execute arbitrary commands or overwrite files, via an HTTP request containing an escape sequence for a terminal emulator.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemswebrickall versions1.4.0bundle update webrick --conservative

Affected Products

1 product · 1 configurations
Application
webrickruby-lang
1 version
1.3.1
Exploits & PoCs
4

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-33489remotemultiple✓ Verified

Ruby 1.9.1 - WEBrick 'Terminal Escape Sequence in Logs' Command Injection

by evilaliv3 · Jan 11, 2010

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for webrick, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update webrick to 1.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2009-4492 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow
ProductFixed inAdvisory
Red Hat Enterprise Linux 4ruby-0:1.8.1-16.el4RHSA-2011:0908
Red Hat Enterprise Linux 5ruby-0:1.8.5-19.el5_6.1RHSA-2011:0909

Frequently Asked Questions

WEBrick 1.3.1 in Ruby 1.8.6 through patchlevel 383, 1.8.7 through patchlevel 248, 1.8.8dev, 1.9.1 through patchlevel 376, and 1.9.2dev writes data to a log file without sanitizing non-printable characters, which might allow remote attackers to modify a window's title, or possibly execute arbitrary commands or overwrite files, via an HTTP request containing an escape sequence for a terminal emulator.
O3 Security · Impact-Aware SCA

Is CVE-2009-4492 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2009-4492: webrick — Fixed in 1.4.0