CVE-2017-10784 is a high-severity (CVSS 8.8) Improper Authentication vulnerability in webrick. EPSS puts its 30-day exploitation probability at 16.4% (97th percentile). A fix is available for webrick — see the affected versions and patch details below.
WEBrick RCE Vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
webrickReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
The Basic authentication code in WEBrick library in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows remote attackers to inject terminal emulator escape sequences into its log and possibly execute arbitrary commands via a crafted user name.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | webrick | all versions | 1.4.0bundle update webrick --conservative |
Affected Products
rubyruby-langDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for webrick, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update webrick to 1.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-10784 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This issue affects the versions of ruby as shipped with Red Hat Enterprise Linux 5, 6, and 7, as well as the versions of rh-ruby22-ruby and rh-ruby23-ruby as shipped with Red Hat Software Collections 3. Red Hat Product Security has rated this issue as having Moderate security impact. A future update may address this…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 7 | ruby-0:2.0.0.648-33.el7_4 | RHSA-2018:0378 |
| Red Hat Software Collections for Red Hat Enterprise Linux 6 | rh-ruby24-ruby-0:2.4.2-86.el6 | RHSA-2017:3485 |
| Red Hat Software Collections for Red Hat Enterprise Linux 6 | rh-ruby22-ruby-0:2.2.9-19.el6 | RHSA-2018:0583 |
| Red Hat Software Collections for Red Hat Enterprise Linux 6 | rh-ruby23-ruby-0:2.3.6-67.el6 | RHSA-2018:0585 |
| Red Hat Hardened Images | ruby3-3-main-3.3.10-23.1.hum1 | RHSA-2026:7305 |
| Red Hat Hardened Images | ruby3-4-main-3.4.8-31.1.hum1 | RHSA-2026:7307 |
| Red Hat Hardened Images | ruby4-0-main-4.0.0-33.3.hum1 | RHSA-2026:8838 |
Frequently Asked Questions
Is CVE-2017-10784 in your dependencies?
Find it across RubyGems, including transitive dependencies.