CVE-2020-25613 is a high-severity (CVSS 7.5) CWE-444 vulnerability in webrick. A fix is available for webrick — see the affected versions and patch details below.
WEBRick vulnerable to HTTP Request/Response Smuggling
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
webrick💎webrick💎webrickReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in Ruby through 2.5.8, 2.6.x through 2.6.6, and 2.7.x through 2.7.1. WEBrick, a simple HTTP server bundled with Ruby, had not checked the transfer-encoding header value rigorously. An attacker may potentially exploit this issue to bypass a reverse proxy (which also has a poor header check), which may lead to an HTTP Request Smuggling attack.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | webrick | ≥ 1.6.0&&< 1.6.1 | 1.6.1bundle update webrick --conservative |
| 💎RubyGems | webrick | ≥ 1.5.0&&< 1.5.1 | 1.5.1bundle update webrick --conservative |
| 💎RubyGems | webrick | all versions | 1.4.4bundle update webrick --conservative |
Affected Products
fedorafedoraprojectrubyruby-langwebrickruby-langDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for webrick, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update webrick to 1.6.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-25613 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 8 | ruby:2.7-8040020210421133318.522a0ee4 | RHSA-2021:2584 |
| Red Hat Enterprise Linux 8 | ruby:2.5-8040020200923213910.522a0ee4 | RHSA-2021:2587 |
| Red Hat Enterprise Linux 8 | ruby:2.6-8040020210430142949.522a0ee4 | RHSA-2021:2588 |
| Red Hat Enterprise Linux 8.1 Update Services for SAP Solutions | ruby:2.6-8010020220201152941.c27ad7f8 | RHSA-2022:0581 |
| Red Hat Enterprise Linux 8.2 Extended Update Support | ruby:2.6-8020020220201131207.4cda2c84 | RHSA-2022:0582 |
| Red Hat Software Collections for Red Hat Enterprise Linux 7 | rh-ruby25-ruby-0:2.5.9-9.el7 | RHSA-2021:2104 |
| Red Hat Software Collections for Red Hat Enterprise Linux 7 | rh-ruby27-ruby-0:2.7.3-129.el7 | RHSA-2021:2229 |
| Red Hat Software Collections for Red Hat Enterprise Linux 7 | rh-ruby26-ruby-0:2.6.7-119.el7 | RHSA-2021:2230 |
Frequently Asked Questions
Is CVE-2020-25613 in your dependencies?
Find it across RubyGems, including transitive dependencies.