NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

Koji Cross-site ScriptingGHSA-g2vg-8hfg-79vj

MEDIUM

GHSA-g2vg-8hfg-79vj is a medium-severity (CVSS 5.4) CWE-116 vulnerability in koji. A fix is available for koji — see the affected versions and patch details below.

Also known asCVE-2024-9427PYSEC-2026-1501
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-g2vg-8hfg-79vj.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs22th percentile — riskier than 22% of all scored CVEsHighest risk
0.00%0.27%0.53%0.80%0.1%0.3%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍koji🐍koji🐍koji

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

A vulnerability in Koji was found. An unsanitized input allows for an XSS attack. Javascript code from a malicious link could be reflected in the resulting web page. It is not expected to be able to submit an action or make a change in Koji due to existing XSS protections in the code.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIkoji≥ 1.35.0&&< 1.35.11.35.1pip install --upgrade 'koji==1.35.1'
🐍PyPIkoji≥ 1.34.0&&< 1.34.31.34.3pip install --upgrade 'koji==1.34.3'
🐍PyPIkojiall versions1.33.2pip install --upgrade 'koji==1.33.2'

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for koji, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update koji to 1.35.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-g2vg-8hfg-79vj is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

A vulnerability in Koji was found. An unsanitized input allows for an XSS attack. Javascript code from a malicious link could be reflected in the resulting web page. It is not expected to be able to submit an action or make a change in Koji due to existing XSS protections in the code.
O3 Security · Impact-Aware SCA

Is GHSA-g2vg-8hfg-79vj in your dependencies?

Find it across PyPI, including transitive dependencies.

Koji Cross-site Scripting (Medium 5.4)