CVE-2018-1002150 — koji
CRITICALCVE-2018-1002150 is a critical-severity (CVSS 9.1) CWE-732 vulnerability in koji. A fix is available for koji — see the affected versions and patch details below.
Koji hub call does not perform correct access checks
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
koji🐍koji🐍koji🐍kojiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Koji version 1.12, 1.13, 1.14 and 1.15 contain an incorrect access control vulnerability resulting in arbitrary filesystem read/write access. This vulnerability has been fixed in versions 1.12.1, 1.13.1, 1.14.1 and 1.15.1.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | koji | ≥ 1.15&&< 1.15.1 | 1.15.1pip install --upgrade 'koji==1.15.1' |
| 🐍PyPI | koji | ≥ 1.14&&< 1.14.1 | 1.14.1pip install --upgrade 'koji==1.14.1' |
| 🐍PyPI | koji | ≥ 1.13&&< 1.13.1 | 1.13.1pip install --upgrade 'koji==1.13.1' |
| 🐍PyPI | koji | ≥ 1.12&&< 1.12.1 | 1.12.1pip install --upgrade 'koji==1.12.1' |
Affected Products
kojikoji_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for koji, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update koji to 1.15.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1002150 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2018-1002150 in your dependencies?
Find it across PyPI, including transitive dependencies.