NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2019-17109 — koji

MEDIUMFix: koji-project/koji@91d6f0b

CVE-2019-17109 is a medium-severity (CVSS 6.5) Path Traversal vulnerability in koji. A fix is available for koji — see the affected versions and patch details below.

koji hub allows arbitrary upload destinations

Also known asPYSEC-2019-183
Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs88th percentile — riskier than 88% of all scored CVEsHighest risk
0.00%1.31%2.62%3.93%0.6%3.2%May 26Sep 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
🐍koji🐍koji🐍koji🐍koji🐍koji

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The way that the hub code validates upload paths allows for an attacker to choose an arbitrary destination for the uploaded file. Uploading still requires login. However, an attacker with credentials could damage the integrity of the Koji system.

Workaround

There is no known workaround. All Koji admins are encouraged to update to a fixed version as soon as possible.

Fix

Koji versions 1.14.3, 1.15.3, 1.16.3, 1.17.1, and 1.18.1 all include patches to solve this vulnerability.

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIkoji≥ 1.14.0&&< 1.14.31.14.3pip install --upgrade 'koji==1.14.3'
🐍PyPIkoji≥ 1.15.0&&< 1.15.31.15.3pip install --upgrade 'koji==1.15.3'
🐍PyPIkoji≥ 1.16.0&&< 1.16.31.16.3pip install --upgrade 'koji==1.16.3'
🐍PyPIkoji≥ 1.17.0&&< 1.17.11.17.1pip install --upgrade 'koji==1.17.1'
🐍PyPIkoji≥ 1.18.0&&< 1.18.11.18.1pip install --upgrade 'koji==1.18.1'

Affected Products

1 product · 1 configurations
Application
kojikoji_project
≤ 1.18.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for koji, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update koji to 1.14.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-17109 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

The way that the hub code validates upload paths allows for an attacker to choose an arbitrary destination for the uploaded file. Uploading still requires login. However, an attacker with credentials could damage the integrity of the Koji system. ### Workaround There is no known workaround. All Koji admins are encouraged to update to a fixed version as soon as possible. ### Fix Koji versions 1.14.3, 1.15.3, 1.16.3, 1.17.1, and 1.18.1 all include patches to solve this vulnerability.
O3 Security · Impact-Aware SCA

Is CVE-2019-17109 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2019-17109: koji — Fixed in 1.14.3