CVE-2017-1002153 — koji
HIGHCVE-2017-1002153 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in koji. A fix is available for koji — see the affected versions and patch details below.
Koji blacklisted paths workaround
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
kojiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Koji 1.13.0 does not properly validate SCM paths, allowing an attacker to work around blacklisted paths for build submission.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | koji | all versions | 1.15.0pip install --upgrade 'koji==1.15.0' |
Affected Products
kojikoji_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for koji, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update koji to 1.15.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-1002153 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2017-1002153 in your dependencies?
Find it across PyPI, including transitive dependencies.