GHSA-g2fg-mr77-6vrm is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in org.apache.thrift:libthrift. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.thrift:libthrift — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.thrift:libthriftReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Apache Thrift 0.9.3 to 0.13.0, malicious RPC clients could send short messages which would result in a large memory allocation, potentially leading to denial of service.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.thrift:libthrift | ≥ 0.9.3&&< 0.14.0 | 0.14.0org.apache.thrift:libthrift:0.14.0 |
Affected Products
hiveapachethriftapachecommunications cloud native core network slice selection functionoraclecommunications cloud native core policyoracleResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.thrift:libthrift, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.thrift:libthrift to 0.14.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-g2fg-mr77-6vrm is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
* A vulnerable version of the libthrift library is delivered in listed OpenShift Container Platform (OCP) and OpenShift Jaeger (Jaeger) components, but the vulnerable code is not invoked, therefore these components are affected but with impact Moderate. * For Red Hat OpenStack, because the fix would require a…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Fuse 7.10 | libthrift | RHSA-2021:5134 |
| Red Hat JBoss Enterprise Application Platform 7.1 EUS for RHEL 7 | eap7-glassfish-el-0:3.0.1-4.b08_redhat_00005.1.ep7.el7 | RHSA-2025:9582 |
| Red Hat OpenShift Jaeger 1.20 | distributed-tracing/jaeger-agent-rhel8:1.20.4-18 | RHSA-2021:2543 |
Frequently Asked Questions
Is GHSA-g2fg-mr77-6vrm in your dependencies?
Find it across Maven, including transitive dependencies.