Improperly checked IDs on itemstacks received from the client leading to server crash in PocketMine-MPGHSA-fqx3-r75h-vc89
HIGHFix: pmmp/PocketMine-MP@5fd685eGHSA-fqx3-r75h-vc89 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in pocketmine/pocketmine-mp. A fix is available for pocketmine/pocketmine-mp — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-fqx3-r75h-vc89.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
pocketmine/pocketmine-mpReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Due to a workaround for unmapped network items implemented in 4.0.0-BETA5 (8ac16345a3bc099b62c1f5cfbf3b736e621c3f76), arbitrary item IDs are able to be written into an item's NBT. The intended purpose of this is to make said unmapped network items able to be moved around the inventory without issues.
This led to an exploit due to internal limits on the range that item IDs can occupy (-32768 - 32767), while the tag type used to represent the replacement IDs for unknown items is a TAG_Int, allowing a range from -(2^31) - 2^31 - 1. This leads to an uncaught exception which crashes the server.
Patches
5fd685e07d61ef670584ed11a52fd5f4b99a81a7
Workarounds
In theory this can be checked by plugins using a custom TypeConverter, but this is likely to be very cumbersome.
For more information
If you have any questions or comments about this advisory:
- Email us at [email protected]
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | pocketmine/pocketmine-mp | ≥ 4.0.0-BETA5&&< 4.4.2 | 4.4.2composer require pocketmine/pocketmine-mp:^4.4.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pocketmine/pocketmine-mp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update pocketmine/pocketmine-mp to 4.4.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-fqx3-r75h-vc89 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-fqx3-r75h-vc89 in your dependencies?
Find it across Packagist, including transitive dependencies.