NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

Apache Kylin vulnerable to Command injection by Useless configurationGHSA-f5q9-j9r2-34gq

HIGHFix: apache/kylin#2011

GHSA-f5q9-j9r2-34gq is a high-severity (CVSS 8.8) CWE-184 vulnerability in org.apache.kylin:kylin. EPSS puts its 30-day exploitation probability at 55.3% (99th percentile). A fix is available for org.apache.kylin:kylin — see the affected versions and patch details below.

Also known asCVE-2022-43396
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-f5q9-j9r2-34gq.

EPSS Exploitation Probability

via FIRST.org ↗
55.3%probability of exploitation in next 30 days
High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
0.00%24.6%49.2%73.8%0.4%55.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.kylin:kylin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In the fix for CVE-2022-24697, a blacklist is used to filter user input commands. But there is a risk of being bypassed. The user can control the command by controlling the kylin.engine.spark-cmd parameter of conf.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.kylin:kylin≥ 2.0.0&&< 4.0.34.0.3org.apache.kylin:kylin:4.0.3

Affected Products

1 product · 1 configurations
Application
kylinapache
< 4.0.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.kylin:kylin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.kylin:kylin to 4.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-f5q9-j9r2-34gq is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

In the fix for CVE-2022-24697, a blacklist is used to filter user input commands. But there is a risk of being bypassed. The user can control the command by controlling the `kylin.engine.spark-cmd` parameter of `conf`.
O3 Security · Impact-Aware SCA

Is GHSA-f5q9-j9r2-34gq in your dependencies?

Find it across Maven, including transitive dependencies.

Apache Kylin vulnerable to Command injection by Useless…