CVE-2022-43396 is a high-severity (CVSS 8.8) CWE-184 vulnerability in org.apache.kylin:kylin. EPSS puts its 30-day exploitation probability at 55.3% (99th percentile). A fix is available for org.apache.kylin:kylin — see the affected versions and patch details below.
Apache Kylin: Command injection by Useless configuration
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-43396.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.kylin:kylinReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In the fix for CVE-2022-24697, a blacklist is used to filter user input commands. But there is a risk of being bypassed. The user can control the command by controlling the kylin.engine.spark-cmd parameter of conf.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.kylin:kylin | ≥ 2.0.0&&< 4.0.3 | 4.0.3org.apache.kylin:kylin:4.0.3 |
Affected Products
kylinapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.kylin:kylin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.kylin:kylin to 4.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-43396 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-43396 in your dependencies?
Find it across Maven, including transitive dependencies.