CVE-2020-13937 — kylin
MEDIUMCVE-2020-13937 is a medium-severity (CVSS 5.3) CWE-922 vulnerability in org.apache.kylin:kylin. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.kylin:kylin — see the affected versions and patch details below.
Authentication bypass in Apache Kylin
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.kylin:kylin☕org.apache.kylin:kylinReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Kylin 2.0.0, 2.1.0, 2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.4.0, 2.4.1, 2.5.0, 2.5.1, 2.5.2, 2.6.0, 2.6.1, 2.6.2, 2.6.3, 2.6.4, 2.6.5, 2.6.6, 3.0.0-alpha, 3.0.0-alpha2, 3.0.0-beta, 3.0.0, 3.0.1, 3.0.2, 3.1.0, 4.0.0-alpha has one restful api which exposed Kylin's configuration information without any authentication, so it is dangerous because some confidential information entries will be disclosed to everyone.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.kylin:kylin | all versions | 3.1.1org.apache.kylin:kylin:3.1.1 |
| ☕Maven | org.apache.kylin:kylin | ≥ 4.0.0-alpha&&< 4.0.0-beta | 4.0.0-betaorg.apache.kylin:kylin:4.0.0-beta |
Affected Products
kylinapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.kylin:kylin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.kylin:kylin to 3.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-13937 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
How to detect CVE-2020-13937
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2020-13937 -u https://target- Template
- Apache Kylin - Exposed Configuration File
- Severity
- medium
- Impact
- An attacker can gain sensitive information from the exposed configuration file, potentially leading to further attacks.
- Remediation
- Secure the configuration file by restricting access permissions and implementing proper access controls.
Template by ProjectDiscovery nuclei-templates (pikpikcu), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2020-13937 in your dependencies?
Find it across Maven, including transitive dependencies.