CVE-2025-61734 is a high-severity (CVSS 7.5) CWE-552 vulnerability in org.apache.kylin:kylin. EPSS puts its 30-day exploitation probability at 26.1% (98th percentile). A fix is available for org.apache.kylin:kylin — see the affected versions and patch details below.
Apache Kylin: improper restriction of file read
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-61734.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.kylin:kylin☕org.apache.kylin:kylin-common-server☕org.apache.kylin:kylin-common-service☕org.apache.kylin:kylin-core-common☕org.apache.kylin:kylin-core-metadata☕org.apache.kylin:kylin-ops-server☕org.apache.kylin:kylin-serverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Files or Directories Accessible to External Parties vulnerability in Apache Kylin. You are fine as long as the Kylin's system and project admin access is well protected.
This issue affects Apache Kylin: from 4.0.0 through 5.0.2.
Users are recommended to upgrade to version 5.0.3, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.kylin:kylin | ≥ 4.0.0&&< 5.0.3 | 5.0.3org.apache.kylin:kylin:5.0.3 |
| ☕Maven | org.apache.kylin:kylin-common-server | ≥ 4.0.0&&< 5.0.3 | 5.0.3org.apache.kylin:kylin-common-server:5.0.3 |
| ☕Maven | org.apache.kylin:kylin-common-service | ≥ 4.0.0&&< 5.0.3 | 5.0.3org.apache.kylin:kylin-common-service:5.0.3 |
| ☕Maven | org.apache.kylin:kylin-core-common | ≥ 4.0.0&&< 5.0.3 | 5.0.3org.apache.kylin:kylin-core-common:5.0.3 |
| ☕Maven | org.apache.kylin:kylin-core-metadata | ≥ 4.0.0&&< 5.0.3 | 5.0.3org.apache.kylin:kylin-core-metadata:5.0.3 |
| ☕Maven | org.apache.kylin:kylin-ops-server | ≥ 4.0.0&&< 5.0.3 | 5.0.3org.apache.kylin:kylin-ops-server:5.0.3 |
Affected Products
kylinapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.kylin:kylin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.kylin:kylin to 5.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-61734 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2025-61734 in your dependencies?
Find it across Maven, including transitive dependencies.