NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

Apache Tomcat vulnerable to Generation of Error Message Containing Sensitive InformationGHSA-f4qf-m5gf-8jm8

MEDIUMFix: apache/tomcat@86ccc43

GHSA-f4qf-m5gf-8jm8 is a medium-severity (CVSS 5.3) CWE-209 vulnerability in org.apache.tomcat:tomcat-coyote. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.tomcat:tomcat-coyote — see the affected versions and patch details below.

Also known asBIT-tomcat-2024-21733CVE-2024-21733
Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
2 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-f4qf-m5gf-8jm8.

EPSS Exploitation Probability

via FIRST.org ↗
14.3%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs97th percentile — riskier than 97% of all scored CVEsHighest risk
0.00%30.4%60.8%91.2%73.4%14.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat.experimental:tomcat-embed-programmatic

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Generation of Error Message Containing Sensitive Information vulnerability in Apache Tomcat.This issue affects Apache Tomcat: from 8.5.7 through 8.5.63, from 9.0.0-M11 through 9.0.43. Other, EOL versions may also be affected.

Users are recommended to upgrade to version 8.5.64 onwards or 9.0.44 onwards, which contain a fix for the issue.

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.tomcat:tomcat-coyote≥ 9.0.0-M11&&< 9.0.449.0.44org.apache.tomcat:tomcat-coyote:9.0.44
☕Mavenorg.apache.tomcat.embed:tomcat-embed-core≥ 8.5.7&&< 8.5.648.5.64org.apache.tomcat.embed:tomcat-embed-core:8.5.64
☕Mavenorg.apache.tomcat.embed:tomcat-embed-core≥ 9.0.0-M11&&< 9.0.449.0.44org.apache.tomcat.embed:tomcat-embed-core:9.0.44
☕Mavenorg.apache.tomcat:tomcat-coyote≥ 8.5.7&&< 8.5.648.5.64org.apache.tomcat:tomcat-coyote:8.5.64
☕Mavenorg.apache.tomcat.experimental:tomcat-embed-programmatic≥ 9.0.43&&< 9.0.449.0.44org.apache.tomcat.experimental:tomcat-embed-programmatic:9.0.44

Affected Products

1 product · 19 configurations
Application
tomcatapache
≥ 9.0.1 && < 9.0.44
1 version
9.0.0
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat-coyote, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.tomcat:tomcat-coyote to 9.0.44 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-f4qf-m5gf-8jm8 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

Red Hat Enterprise Linux remains unaffected as the vulnerable version of Tomcat (e.g., versions 8.5.7 through 8.5.63 and 9.0.0 through 9.0.43) has not been shipped or included.

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for GHSA-f4qf-m5gf-8jm8 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat build of Apache Camel 4.4.0 for Spring BoottomcatRHSA-2024:2707
Red Hat Fuse 7.13.0tomcatRHSA-2024:3354

Frequently Asked Questions

Generation of Error Message Containing Sensitive Information vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 8.5.7 through 8.5.63, from 9.0.0-M11 through 9.0.43. Users are recommended to upgrade to version 8.5.64 onwards or 9.0.44 onwards, which contain a fix for the issue.
O3 Security · Impact-Aware SCA

Is GHSA-f4qf-m5gf-8jm8 in your dependencies?

Find it across Maven, including transitive dependencies.

Apache Tomcat vulnerable to Generation of Error…