Pysaml2 improperly initializes encryption vectorGHSA-cq94-qf6q-mf2h
MEDIUMFix: IdentityPython/pysaml2#519GHSA-cq94-qf6q-mf2h is a medium-severity (CVSS 5.3) Insufficient Random Values vulnerability in pysaml2. A fix is available for pysaml2 — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
pysaml2Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Python package pysaml2 version 4.5.0 and earlier reuses the initialization vector across encryptions in the IDP server, resulting in weak encryption of data.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | pysaml2 | all versions | 4.6.0pip install --upgrade 'pysaml2==4.6.0' |
Affected Products
pysaml2pysaml2_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pysaml2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update pysaml2 to 4.6.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-cq94-qf6q-mf2h is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-cq94-qf6q-mf2h in your dependencies?
Find it across PyPI, including transitive dependencies.