Moderate severity vulnerability that affects org.apache.mesos:mesosGHSA-c8cc-p3j7-4c7f
MEDIUMGHSA-c8cc-p3j7-4c7f is a medium-severity (CVSS 5.9) Information Exposure vulnerability in org.apache.mesos:mesos. A fix is available for org.apache.mesos:mesos — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.mesos:mesos☕org.apache.mesos:mesos☕org.apache.mesos:mesosReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Mesos can be configured to require authentication to call the Executor HTTP API using JSON Web Token (JWT). In Apache Mesos versions pre-1.4.2, 1.5.0, 1.5.1, 1.6.0 the comparison of the generated HMAC value against the provided signature in the JWT implementation used is vulnerable to a timing attack because instead of a constant-time string comparison routine a standard == operator has been used. A malicious actor can therefore abuse the timing difference of when the JWT validation function returns to reveal the correct HMAC value.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.mesos:mesos | all versions | 1.4.2org.apache.mesos:mesos:1.4.2 |
| ☕Maven | org.apache.mesos:mesos | ≥ 1.5.0&&< 1.5.2 | 1.5.2org.apache.mesos:mesos:1.5.2 |
| ☕Maven | org.apache.mesos:mesos | ≥ 1.6.0&&< 1.6.1 | 1.6.1org.apache.mesos:mesos:1.6.1 |
Affected Products
mesosapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.mesos:mesos, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.mesos:mesos to 1.4.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-c8cc-p3j7-4c7f is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is GHSA-c8cc-p3j7-4c7f in your dependencies?
Find it across Maven, including transitive dependencies.