phpBB Server-Side Request Forgery (SSRF)GHSA-9jm4-rg99-566c
HIGHGHSA-9jm4-rg99-566c is a high-severity (CVSS 7.5) Server-Side Request Forgery (SSRF) vulnerability in phpbb/phpbb. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for phpbb/phpbb — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
phpbb/phpbbReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
phpBB version 3.2.0 is vulnerable to SSRF in the Remote Avatar function resulting allowing an attacker to perform port scanning, requesting internal content and potentially attacking such internal services via the web application.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | phpbb/phpbb | ≥ 3.2.0&&< 3.2.1 | 3.2.1composer require phpbb/phpbb:^3.2.1 |
Affected Products
phpbbphpbbResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpbb/phpbb, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update phpbb/phpbb to 3.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-9jm4-rg99-566c is resolved across your whole dependency graph.
Workarounds
Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.
Frequently Asked Questions
Is GHSA-9jm4-rg99-566c in your dependencies?
Find it across Packagist, including transitive dependencies.