NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2020-5501 — phpbb

MEDIUM

CVE-2020-5501 is a medium-severity (CVSS 4.3) Cross-Site Request Forgery (CSRF) vulnerability in phpbb/phpbb. A fix is available for phpbb/phpbb — see the affected versions and patch details below.

phpBB Cross-Site Request Forgery (CSRF)

Also known asBIT-phpbb-2020-5501GHSA-cpqc-g4r8-6hxg
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs32th percentile — riskier than 32% of all scored CVEsHighest risk
0.00%0.29%0.58%0.88%0.1%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘phpbb/phpbb

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

phpBB 3.2.8 allows a CSRF attack that can modify a group avatar.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistphpbb/phpbb≥ 3.2.8&&< 3.2.93.2.9composer require phpbb/phpbb:^3.2.9

Affected Products

1 product · 1 configurations
Application
phpbbphpbb
1 version
3.2.8

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpbb/phpbb, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update phpbb/phpbb to 3.2.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-5501 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

phpBB 3.2.8 allows a CSRF attack that can modify a group avatar.
O3 Security · Impact-Aware SCA

Is CVE-2020-5501 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2020-5501: phpbb CSRF — Fixed in 3.2.9