CVE-2019-16108 — phpbb
HIGHCVE-2019-16108 is a high-severity (CVSS 7.5) Code Injection vulnerability in phpbb/phpbb. A fix is available for phpbb/phpbb — see the affected versions and patch details below.
phpBB arbitrary CSS injection
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
phpbb/phpbbReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
phpBB 3.2.7 allows adding an arbitrary Cascading Style Sheets (CSS) token sequence to a page through BBCode.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | phpbb/phpbb | ≥ 3.2.7&&< 3.2.8 | 3.2.8composer require phpbb/phpbb:^3.2.8 |
Affected Products
phpbbphpbbDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpbb/phpbb, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update phpbb/phpbb to 3.2.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-16108 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2019-16108 in your dependencies?
Find it across Packagist, including transitive dependencies.