NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2019-9826 — phpbb

HIGH

CVE-2019-9826 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in phpbb/phpbb. A fix is available for phpbb/phpbb — see the affected versions and patch details below.

phpBB Denial of Service

Also known asGHSA-6pgr-x867-h7jx
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs81th percentile — riskier than 81% of all scored CVEsHighest risk
0.14%1.03%1.91%2.80%0.6%2.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘phpbb/phpbb

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The fulltext search component in phpBB before 3.2.6 allows Denial of Service.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistphpbb/phpbball versions3.2.6composer require phpbb/phpbb:^3.2.6

Affected Products

1 product · 1 configurations
Application
phpbbphpbb
≤ 3.2.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpbb/phpbb, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update phpbb/phpbb to 3.2.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-9826 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

The fulltext search component in phpBB before 3.2.6 allows Denial of Service.
O3 Security · Impact-Aware SCA

Is CVE-2019-9826 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2019-9826: phpbb DoS — Fixed in 3.2.6