NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

Adminer file disclosure vulnerabilityGHSA-97h7-mf38-g9mf

HIGHFix: vrana/adminer@c564a8e

GHSA-97h7-mf38-g9mf is a high-severity (CVSS 7.5) vulnerability in vrana/adminer. A fix is available for vrana/adminer — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Dec 4, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected
🐘vrana/adminer

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Adminer script versions up to 4.6.2 contains file disclosure vulnerability.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistvrana/adminer≥ 4.3.1&&< 4.6.34.6.3composer require vrana/adminer:^4.6.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for vrana/adminer, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update vrana/adminer to 4.6.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-97h7-mf38-g9mf is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Adminer script versions up to 4.6.2 contains file disclosure vulnerability.
O3 Security · Impact-Aware SCA

Is GHSA-97h7-mf38-g9mf in your dependencies?

Find it across Packagist, including transitive dependencies.

Adminer file disclosure vulnerability (High 7.5)