Your RSA-2048 keys break in 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2018-7667 — adminer

CRITICALFix: vrana/adminer@35bfaa7

CVE-2018-7667 is a critical-severity (CVSS 9.8) Server-Side Request Forgery (SSRF) vulnerability in vrana/adminer. 1 public exploit reference exists, so weaponization risk is real. A fix is available for vrana/adminer — see the affected versions and patch details below.

vrana/adminer vulnerable to SSRF by connecting to privileged ports

Also known asGHSA-43f8-p5w3-5m25
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 24, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
5.0%probability of exploitation in next 30 days
Lower Risk+0.53%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
0.70%7.36%14.0%20.7%16.9%5.0%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

CVE-2018-7667 by exploitation likelihood (EPSS) against impact (CVSS). Outside the shaded patch-first corner.

Where this sits among everything scored

Of 395,492 CVEs with a current EPSS score, this one falls in the < 10% band (highlighted). Counts from FIRST.org, log-scaled.

Real-World Exposure

1 pkg affected
🐘vrana/adminer

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact

All users are affected.

Patches

  • Unsuccessfully patched by 0fae40fb, included in version 4.4.0.
  • Patched by 35bfaa75, included in version 4.7.8.

Workarounds

Protect access to Adminer also by other means, e.g. by HTTP password, IP address limiting or by OTP plugin.

References

For more information

If you have any questions or comments about this advisory:

  • Comment at 35bfaa75.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistvrana/adminerall versions4.7.8composer require vrana/adminer:^4.7.8

Affected Products

1 product · 1 configurations
Application
admineradminer
≤ 4.3.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for vrana/adminer, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update vrana/adminer to 4.7.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-7667 is resolved across your whole dependency graph.

  3. Workarounds

    Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.

Frequently Asked Questions

### Impact All users are affected. ### Patches * Unsuccessfully patched by 0fae40fb, included in version [4.4.0](https://github.com/vrana/adminer/releases/tag/v4.4.0). * Patched by 35bfaa75, included in version [4.7.8](https://github.com/vrana/adminer/releases/tag/v4.7.8). ### Workarounds Protect access to Adminer also by other means, e.g. by HTTP password, IP address limiting or by OTP [plugin](https://www.adminer.org/plugins/). ### References * http://hyp3rlinx.altervista.org/advisories/ADMINER-UNAUTHENTICATED-SERVER-SIDE-REQUEST-FORGERY.txt * https://sourceforge.net/p/adminer/bugs-and-fe
O3 Security · Impact-Aware SCA

Is CVE-2018-7667 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2018-7667: adminer SSRF — Fixed in 4.7.8