CVE-2021-43008 — adminer
HIGHCVE-2021-43008 is a high-severity (CVSS 7.5) vulnerability in vrana/adminer. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for vrana/adminer — see the affected versions and patch details below.
Files or Directories Accessible to External Parties in Adminer
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
vrana/adminerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Improper Access Control in Adminer versions 1.12.0 to 4.6.2 (fixed in version 4.6.3) allows an attacker to achieve Arbitrary File Read on the remote server by requesting the Adminer to connect to a remote MySQL database.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | vrana/adminer | ≥ 1.12.0&&< 4.6.3 | 4.6.3composer require vrana/adminer:^4.6.3 |
Affected Products
admineradminerdebian linuxdebianResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for vrana/adminer, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update vrana/adminer to 4.6.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-43008 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2021-43008 in your dependencies?
Find it across Packagist, including transitive dependencies.