Your RSA-2048 keys break in 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
CISA KEV · ACTIVELY EXPLOITED
HIGH severity

CVE-2021-21311 — adminer

HIGHFix: vrana/adminer@ccd2374

CVE-2021-21311 is a high-severity (CVSS 7.2) Server-Side Request Forgery (SSRF) vulnerability in vrana/adminer. It is in CISA's Known Exploited Vulnerabilities catalog (added 2025-09-29) — treat it as actively exploited and patch now. A fix is available for vrana/adminer — see the affected versions and patch details below.

SSRF in adminer

Also known asGHSA-x5r2-hj5c-8jx6
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
4 known
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, CISA KEV, FIRST.org (EPSS)

Exploitation Status

Actively exploited in the wild

  • Confirmed by CISA's Known Exploited Vulnerabilities catalog on 2025-09-29. Federal agencies were required to remediate by 2025-10-20.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.

Exploitation and automatability from CISA (KEV catalog and SSVC triage) for CVE-2021-21311.

EPSS Exploitation Probability

via FIRST.org ↗
98.5%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
88.1%92.0%96.0%100.0%94.2%98.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

CVE-2021-21311 by exploitation likelihood (EPSS) against impact (CVSS). In the shaded patch-first corner (EPSS 50%+, CVSS 7.0+).

Where this sits among everything scored

Of 395,249 CVEs with a current EPSS score, this one falls in the ≥ 90% band (highlighted). Counts from FIRST.org, log-scaled.

Real-World Exposure

1 pkg affected
🐘vrana/adminer

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Users of Adminer versions bundling all drivers (e.g. adminer.php) are affected.

Patches

Patched by ccd2374b, included in version 4.7.9.

Workarounds

  • Use a single driver version (e.g. adminer-mysql.php).
  • Protect access to Adminer also by other means, e.g. by HTTP password, IP address limiting or by OTP plugin.

References

https://github.com/vrana/adminer/files/5957311/Adminer.SSRF.pdf

For more information

If you have any questions or comments about this advisory:

  • Comment at ccd2374b.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistvrana/adminerall versions4.7.9composer require vrana/adminer:^4.7.9

Affected Products

2 products · 2 configurations
Application
admineradminer
≥ 4.0.0 && < 4.7.9
range
OS
debian linuxdebian
1 version
9.0
Exploits & PoCs
4

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for vrana/adminer, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update vrana/adminer to 4.7.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-21311 is resolved across your whole dependency graph.

  3. Workarounds

    Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.

How to detect CVE-2021-21311

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2021-21311 -u https://target
Template
Adminer <4.7.9 - Server-Side Request Forgery
Severity
high
Impact
Successful exploitation of this vulnerability could lead to unauthorized access to internal resources and potential data leakage.
Remediation
Upgrade to version 4.7.9 or later.

Template by ProjectDiscovery nuclei-templates (Adam Crosser, pwnhxl), MIT licensed. View the full template. Scan only systems you are authorised to test.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Frequently Asked Questions

### Impact Users of Adminer versions bundling all drivers (e.g. `adminer.php`) are affected. ### Patches Patched by ccd2374b, included in version [4.7.9](https://github.com/vrana/adminer/releases/tag/v4.7.9). ### Workarounds * Use a single driver version (e.g. `adminer-mysql.php`). * Protect access to Adminer also by other means, e.g. by HTTP password, IP address limiting or by OTP [plugin](https://www.adminer.org/plugins/). ### References https://github.com/vrana/adminer/files/5957311/Adminer.SSRF.pdf ### For more information If you have any questions or comments about this advisory: * Co
O3 Security · Impact-Aware SCA

Is CVE-2021-21311 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2021-21311: adminer SSRF (High 7.2, KEV)