NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🦀
🦀 crates.io
Not in CISA KEV
HIGH severity

Tor Arti's STUB circuits incorrectly have a length of 2GHSA-9328-gcfq-p269

HIGH

GHSA-9328-gcfq-p269 is a high-severity (CVSS 7.5) CWE-670 vulnerability in arti. A fix is available for arti — see the affected versions and patch details below.

Also known asCVE-2024-35312CVE-2024-35313GHSA-c96h-cxx6-rmg9RUSTSEC-2024-0339RUSTSEC-2024-0340TROVE-2024-003
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-9328-gcfq-p269.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs8th percentile — riskier than 8% of all scored CVEsHighest risk
0.00%0.23%0.46%0.69%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🦀arti🦀tor-circmgr

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.

Description

In Tor Arti before 1.2.3, STUB circuits incorrectly have a length of 2 (with lite vanguards), aka TROVE-2024-003.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🦀crates.ioarti≥ 1.2.2&&< 1.2.31.2.3cargo update -p arti --precise 1.2.3
🦀crates.iotor-circmgr≥ 0.18.0&&< 0.18.10.18.1cargo update -p tor-circmgr --precise 0.18.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for arti, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update arti to 1.2.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-9328-gcfq-p269 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

In Tor Arti before 1.2.3, STUB circuits incorrectly have a length of 2 (with lite vanguards), aka TROVE-2024-003.
O3 Security · Impact-Aware SCA

Is GHSA-9328-gcfq-p269 in your dependencies?

Find it across crates.io, including transitive dependencies.

Tor Arti's STUB circuits incorrectly have a length of 2