CVE-2024-35312 — arti
MEDIUMCVE-2024-35312 is a medium-severity (CVSS 6.2) CWE-670 vulnerability in arti. A fix is available for arti — see the affected versions and patch details below.
Tor Arti's STUB circuits incorrectly have a length of 2
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-35312.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
arti🦀tor-circmgrReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
In Tor Arti before 1.2.3, STUB circuits incorrectly have a length of 2 (with lite vanguards), aka TROVE-2024-003.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | arti | ≥ 1.2.2&&< 1.2.3 | 1.2.3cargo update -p arti --precise 1.2.3 |
| 🦀crates.io | tor-circmgr | ≥ 0.18.0&&< 0.18.1 | 0.18.1cargo update -p tor-circmgr --precise 0.18.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for arti, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update arti to 1.2.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-35312 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2024-35312 in your dependencies?
Find it across crates.io, including transitive dependencies.