phpMyAdmin Unsafe comparison of XSRF/CSRF tokenGHSA-8m97-xc46-rw9w
HIGHFix: phpmyadmin/phpmyadmin@ec0e88eGHSA-8m97-xc46-rw9w is a high-severity (CVSS 7.5) CWE-254 vulnerability in phpmyadmin/phpmyadmin. A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadminReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
libraries/common.inc.php in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 does not use a constant-time algorithm for comparing CSRF tokens, which makes it easier for remote attackers to bypass intended access restrictions by measuring time differences.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | phpmyadmin/phpmyadmin | ≥ 4.0&&< 4.0.10.13 | 4.0.10.13composer require phpmyadmin/phpmyadmin:^4.0.10.13 |
| 🐘Packagist | phpmyadmin/phpmyadmin | ≥ 4.4&&< 4.4.15.3 | 4.4.15.3composer require phpmyadmin/phpmyadmin:^4.4.15.3 |
| 🐘Packagist | phpmyadmin/phpmyadmin | ≥ 4.5&&< 4.5.4 | 4.5.4composer require phpmyadmin/phpmyadmin:^4.5.4 |
Affected Products
fedorafedoraprojectleapopensuseopensuseopensusephpmyadminphpmyadminDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update phpmyadmin/phpmyadmin to 4.0.10.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8m97-xc46-rw9w is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-8m97-xc46-rw9w in your dependencies?
Find it across Packagist, including transitive dependencies.