NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2016-2041 — phpmyadmin

HIGHFix: phpmyadmin/phpmyadmin@ec0e88e

CVE-2016-2041 is a high-severity (CVSS 7.5) CWE-254 vulnerability in phpmyadmin/phpmyadmin. A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.

phpMyAdmin Unsafe comparison of XSRF/CSRF token

Also known asGHSA-8m97-xc46-rw9w
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs85th percentile — riskier than 85% of all scored CVEsHighest risk
0.53%1.40%2.27%3.15%1.0%2.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadmin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

libraries/common.inc.php in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 does not use a constant-time algorithm for comparing CSRF tokens, which makes it easier for remote attackers to bypass intended access restrictions by measuring time differences.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistphpmyadmin/phpmyadmin≥ 4.0&&< 4.0.10.134.0.10.13composer require phpmyadmin/phpmyadmin:^4.0.10.13
🐘Packagistphpmyadmin/phpmyadmin≥ 4.4&&< 4.4.15.34.4.15.3composer require phpmyadmin/phpmyadmin:^4.4.15.3
🐘Packagistphpmyadmin/phpmyadmin≥ 4.5&&< 4.5.44.5.4composer require phpmyadmin/phpmyadmin:^4.5.4

Affected Products

4 products · 50 configurations
OS
fedorafedoraproject
2 versions
2223
OS
leapopensuse
1 version
42.1
OS
opensuseopensuse
2 versions
13.113.2
Application
phpmyadminphpmyadmin
43 versions
4.0.04.0.14.0.104.0.10.14.0.10.24.0.10.34.0.10.44.0.10.54.0.10.64.0.10.74.0.10.84.0.10.9

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update phpmyadmin/phpmyadmin to 4.0.10.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-2041 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

libraries/common.inc.php in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 does not use a constant-time algorithm for comparing CSRF tokens, which makes it easier for remote attackers to bypass intended access restrictions by measuring time differences.
O3 Security · Impact-Aware SCA

Is CVE-2016-2041 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2016-2041: phpmyadmin CSRF — Fixed in 4.0.10.13