NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2019-12922 — phpmyadmin

MEDIUMFix: phpmyadmin/phpmyadmin@427fbed

CVE-2019-12922 is a medium-severity (CVSS 6.5) Cross-Site Request Forgery (CSRF) vulnerability in phpmyadmin/phpmyadmin. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.

phpMyAdmin Cross-Site Request Forgery (CSRF)

Also known asGHSA-4c9q-64gq-xhx4
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
4 known
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
10.7%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs96th percentile — riskier than 96% of all scored CVEsHighest risk
0.50%17.6%34.8%51.9%42.3%10.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘phpmyadmin/phpmyadmin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A CSRF issue in phpMyAdmin 4.9.0.1 allows deletion of any server in the Setup page.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistphpmyadmin/phpmyadminall versions4.9.1composer require phpmyadmin/phpmyadmin:^4.9.1

Affected Products

2 products · 4 configurations
OS
fedorafedoraproject
3 versions
293031
Application
phpmyadminphpmyadmin
≤ 4.9.0.1
range
Exploits & PoCs
4

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-47385webappsphp

phpMyAdmin 4.9.0.1 - Cross-Site Request Forgery

by Manuel García Cárdenas · Sep 13, 2019

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update phpmyadmin/phpmyadmin to 4.9.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-12922 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

A CSRF issue in phpMyAdmin 4.9.0.1 allows deletion of any server in the Setup page.
O3 Security · Impact-Aware SCA

Is CVE-2019-12922 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2019-12922: phpmyadmin CSRF — Fixed in 4.9.1