NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2020-26935 — phpmyadmin

CRITICAL

CVE-2020-26935 is a critical-severity (CVSS 9.8) SQL Injection vulnerability in phpmyadmin/phpmyadmin. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.

phpMyAdmin SQL injection vulnerability

Also known asBIT-phpmyadmin-2020-26935GHSA-7ff4-cv53-4cjq
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
63.7%probability of exploitation in next 30 days
High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
55.4%70.2%85.0%99.9%91.5%63.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadmin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in SearchController in phpMyAdmin before 4.9.6 and 5.x before 5.0.3. A SQL injection vulnerability was discovered in how phpMyAdmin processes SQL statements in the search feature. An attacker could use this flaw to inject malicious SQL in to a query.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistphpmyadmin/phpmyadmin≥ 4.9.0&&< 4.9.64.9.6composer require phpmyadmin/phpmyadmin:^4.9.6
🐘Packagistphpmyadmin/phpmyadmin≥ 5.0.0&&< 5.0.35.0.3composer require phpmyadmin/phpmyadmin:^5.0.3

Affected Products

5 products · 11 configurations
OS
debian linuxdebian
1 version
9.0
OS
fedorafedoraproject
3 versions
313233
Application
backports sleopensuse
1 version
15.0
OS
leapopensuse
2 versions
15.115.2
Application
phpmyadminphpmyadmin
≥ 5.0.0 && < 5.0.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update phpmyadmin/phpmyadmin to 4.9.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-26935 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

How to detect CVE-2020-26935

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2020-26935 -u https://target
Template
phpMyAdmin < 5.0.3 - SQL Injection
Severity
critical
Impact
Attackers can execute arbitrary SQL commands, potentially leading to data theft, modification, or deletion.
Remediation
Update to phpMyAdmin 4.9.6 or 5.0.3, or latest version.

Template by ProjectDiscovery nuclei-templates (0x_Akoko), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

An issue was discovered in SearchController in phpMyAdmin before 4.9.6 and 5.x before 5.0.3. A SQL injection vulnerability was discovered in how phpMyAdmin processes SQL statements in the search feature. An attacker could use this flaw to inject malicious SQL in to a query.
O3 Security · Impact-Aware SCA

Is CVE-2020-26935 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2020-26935: phpmyadmin — Fixed in 4.9.6