Exposure of Sensitive Information to an Unauthorized Actor in Apache Spark via crafted URLGHSA-8cw6-5qvp-q3wj
MEDIUMGHSA-8cw6-5qvp-q3wj is a medium-severity (CVSS 5.4) Information Exposure vulnerability in org.apache.spark:spark-core_2.10. A fix is available for org.apache.spark:spark-core_2.10 — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.spark:spark-core_2.10☕org.apache.spark:spark-core_2.10☕org.apache.spark:spark-core_2.11☕org.apache.spark:spark-core_2.11☕org.apache.spark:spark-core_2.11Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Apache Spark 2.1.0 to 2.1.2, 2.2.0 to 2.2.1, and 2.3.0, it's possible for a malicious user to construct a URL pointing to a Spark cluster's UI's job and stage info pages, and if a user can be tricked into accessing the URL, can be used to cause script to execute and expose information from the user's view of the Spark UI. While some browsers like recent versions of Chrome and Safari are able to block this type of attack, current versions of Firefox (and possibly others) do not.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.spark:spark-core_2.10 | ≥ 2.1.0&&< 2.1.3 | 2.1.3org.apache.spark:spark-core_2.10:2.1.3 |
| ☕Maven | org.apache.spark:spark-core_2.10 | ≥ 2.2.0&&< 2.2.2 | 2.2.2org.apache.spark:spark-core_2.10:2.2.2 |
| ☕Maven | org.apache.spark:spark-core_2.11 | ≥ 2.1.0&&< 2.1.3 | 2.1.3org.apache.spark:spark-core_2.11:2.1.3 |
| ☕Maven | org.apache.spark:spark-core_2.11 | ≥ 2.2.0&&< 2.2.2 | 2.2.2org.apache.spark:spark-core_2.11:2.2.2 |
| ☕Maven | org.apache.spark:spark-core_2.11 | ≥ 2.3.0&&< 2.3.1 | 2.3.1org.apache.spark:spark-core_2.11:2.3.1 |
Affected Products
sparkapachefirefoxmozillaDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.spark:spark-core_2.10, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.spark:spark-core_2.10 to 2.1.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8cw6-5qvp-q3wj is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
How to detect GHSA-8cw6-5qvp-q3wj
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id ghsa-8cw6-5qvp-q3wj -u https://target- Template
- Apache Spark UI - Cross-Site Scripting
- Severity
- medium
- Impact
- Attackers can execute arbitrary JavaScript in victims' browsers via crafted query string parameters, potentially stealing session cookies or performing actions on behalf of users.
- Remediation
- Upgrade to Apache Spark version 2.3.2 or later.
Template by ProjectDiscovery nuclei-templates (ritikchaddha), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is GHSA-8cw6-5qvp-q3wj in your dependencies?
Find it across Maven, including transitive dependencies.