CVE-2022-31777 is a medium-severity (CVSS 5.4) CWE-74 vulnerability in org.apache.spark:spark-core_2.9.3. A fix is available for org.apache.spark:spark-core_2.9.3 — see the affected versions and patch details below.
Apache Spark XSS vulnerability in log viewer UI Javascript
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-31777.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.spark:spark-core_2.9.3☕org.apache.spark:spark-core_2.13☕org.apache.spark:spark-core_2.13☕org.apache.spark:spark-core_2.12☕org.apache.spark:spark-core_2.12☕org.apache.spark:spark-core_2.11☕org.apache.spark:spark-core_2.10🐍pyspark+1 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A stored cross-site scripting (XSS) vulnerability in Apache Spark 3.2.1 and earlier, and 3.3.0, allows remote attackers to execute arbitrary JavaScript in the web browser of a user, by including a malicious payload into the logs which would be returned in logs rendered in the UI.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.spark:spark-core_2.9.3 | all versions | No fix |
| ☕Maven | org.apache.spark:spark-core_2.13 | all versions | 3.2.2org.apache.spark:spark-core_2.13:3.2.2 |
| ☕Maven | org.apache.spark:spark-core_2.13 | ≥ 3.3.0&&< 3.3.1 | 3.3.1org.apache.spark:spark-core_2.13:3.3.1 |
| ☕Maven | org.apache.spark:spark-core_2.12 | all versions | 3.2.2org.apache.spark:spark-core_2.12:3.2.2 |
| ☕Maven | org.apache.spark:spark-core_2.12 | ≥ 3.3.0&&< 3.3.1 | 3.3.1org.apache.spark:spark-core_2.12:3.3.1 |
| ☕Maven | org.apache.spark:spark-core_2.11 | all versions | No fix |
Affected Products
sparkapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.spark:spark-core_2.9.3, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
A fix is available for CVE-2022-31777; check the affected-versions list above or the advisory for the patched release of org.apache.spark:spark-core_2.9.3, then make sure no transitive dependency still pins the vulnerable range.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| RHINT Camel-Springboot 3.20.1 | apache-spark | RHSA-2023:2100 |
Frequently Asked Questions
Is CVE-2022-31777 in your dependencies?
Find it across Maven, PyPI, including transitive dependencies.