CVE-2023-22946 is a medium-severity (CVSS 6.4) Improper Privilege Management vulnerability in org.apache.spark:spark-core_2.12. A fix is available for org.apache.spark:spark-core_2.12 — see the affected versions and patch details below.
Apache Spark proxy-user privilege escalation from malicious configuration class
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-22946.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.spark:spark-core_2.12☕org.apache.spark:spark-core_2.13🐍pysparkReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven, PyPI packages — download data is not available via public APIs for these ecosystems.
Description
In Apache Spark versions prior to versions 3.4.0 and 3.3.3, applications using spark-submit can specify a proxy-user to run as, limiting privileges. The application can execute code with the privileges of the submitting user, however, by providing malicious configuration-related classes on the classpath. This affects architectures relying on proxy-user, for example those using Apache Livy to manage submitted applications.
Update to Apache Spark 3.4.0, 3.3.3, or later, and ensure that spark.submit.proxyUser.allowCustomClasspathInClusterMode is set to its default of "false", and is not overridden by submitted applications.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.spark:spark-core_2.12 | all versions | 3.3.3org.apache.spark:spark-core_2.12:3.3.3 |
| ☕Maven | org.apache.spark:spark-core_2.13 | all versions | 3.3.3org.apache.spark:spark-core_2.13:3.3.3 |
| 🐍PyPI | pyspark | all versions | 3.3.2pip install --upgrade 'pyspark==3.3.2' |
Affected Products
sparkapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.spark:spark-core_2.12, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.spark:spark-core_2.12 to 3.3.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-22946 is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Frequently Asked Questions
Is CVE-2023-22946 in your dependencies?
Find it across Maven, PyPI, including transitive dependencies.