CVE-2020-9480 — spark-parent_2.11
CRITICALCVE-2020-9480 is a critical-severity (CVSS 9.8) Missing Authentication vulnerability in org.apache.spark:spark-parent_2.11. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.spark:spark-parent_2.11 — see the affected versions and patch details below.
Improper Authentication in Apache Spark
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.spark:spark-parent_2.11🐍pysparkReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven, PyPI packages — download data is not available via public APIs for these ecosystems.
Description
In Apache Spark 2.4.5 and earlier, a standalone resource manager's master may be configured to require authentication (spark.authenticate) via a shared secret. When enabled, however, a specially-crafted RPC to the master can succeed in starting an application's resources on the Spark cluster, even without the shared key. This can be leveraged to execute shell commands on the host machine. This does not affect Spark clusters using other resource managers (YARN, Mesos, etc).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.spark:spark-parent_2.11 | all versions | 2.4.6org.apache.spark:spark-parent_2.11:2.4.6 |
| 🐍PyPI | pyspark | all versions | 2.4.6pip install --upgrade 'pyspark==2.4.6' |
Affected Products
sparkapachebusiness intelligenceoracleResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.spark:spark-parent_2.11, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.spark:spark-parent_2.11 to 2.4.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-9480 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
How to detect CVE-2020-9480
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2020-9480 -u https://target- Template
- Apache Spark - Authentication Bypass
- Severity
- critical
- Impact
- Attackers can execute arbitrary shell commands on the host machine, leading to full system compromise.
- Remediation
- Update to Spark 2.4.6 or later to fix the vulnerability.
Template by ProjectDiscovery nuclei-templates (riteshs4hu), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2020-9480 in your dependencies?
Find it across Maven, PyPI, including transitive dependencies.