CVE-2017-12612 — spark-core_2.11
HIGHCVE-2017-12612 is a high-severity (CVSS 7.8) Deserialization of Untrusted Data vulnerability in org.apache.spark:spark-core_2.11. A fix is available for org.apache.spark:spark-core_2.11 — see the affected versions and patch details below.
Apache Spark Deserialization of Untrusted Data vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.spark:spark-core_2.11☕org.apache.spark:spark-core_2.10🐍pysparkReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven, PyPI packages — download data is not available via public APIs for these ecosystems.
Description
In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. This makes applications launched programmatically using the launcher API potentially vulnerable to arbitrary code execution by an attacker with access to any user account on the local machine. It does not affect apps run by spark-submit or spark-shell. The attacker would be able to execute code as the user that ran the Spark application. Users are encouraged to update to version 2.1.2, 2.2.0 or later.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.spark:spark-core_2.11 | all versions | 2.1.2org.apache.spark:spark-core_2.11:2.1.2 |
| ☕Maven | org.apache.spark:spark-core_2.10 | all versions | 2.1.2org.apache.spark:spark-core_2.10:2.1.2 |
| 🐍PyPI | pyspark | all versions | 2.1.2pip install --upgrade 'pyspark==2.1.2' |
Affected Products
sparkapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.spark:spark-core_2.11, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.spark:spark-core_2.11 to 2.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-12612 is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Frequently Asked Questions
Is CVE-2017-12612 in your dependencies?
Find it across Maven, PyPI, including transitive dependencies.