NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven🐍 PyPI
Not in CISA KEV
HIGH severity

Apache Spark Deserialization of Untrusted Data vulnerabilityGHSA-8rhc-48pp-52gr

HIGH

GHSA-8rhc-48pp-52gr is a high-severity (CVSS 7.8) Deserialization of Untrusted Data vulnerability in org.apache.spark:spark-core_2.11. A fix is available for org.apache.spark:spark-core_2.11 — see the affected versions and patch details below.

Also known asCVE-2017-12612PYSEC-2017-147
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs55th percentile — riskier than 55% of all scored CVEsHighest risk
0.00%0.41%0.82%1.23%0.1%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕org.apache.spark:spark-core_2.11☕org.apache.spark:spark-core_2.10🐍pyspark

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven, PyPI packages — download data is not available via public APIs for these ecosystems.

Description

In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. This makes applications launched programmatically using the launcher API potentially vulnerable to arbitrary code execution by an attacker with access to any user account on the local machine. It does not affect apps run by spark-submit or spark-shell. The attacker would be able to execute code as the user that ran the Spark application. Users are encouraged to update to version 2.1.2, 2.2.0 or later.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.spark:spark-core_2.11all versions2.1.2org.apache.spark:spark-core_2.11:2.1.2
☕Mavenorg.apache.spark:spark-core_2.10all versions2.1.2org.apache.spark:spark-core_2.10:2.1.2
🐍PyPIpysparkall versions2.1.2pip install --upgrade 'pyspark==2.1.2'

Affected Products

1 product · 9 configurations
Application
sparkapache
9 versions
1.6.01.6.11.6.21.6.32.0.02.0.12.0.22.1.02.1.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.spark:spark-core_2.11, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.spark:spark-core_2.11 to 2.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8rhc-48pp-52gr is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Frequently Asked Questions

In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. This makes applications launched programmatically using the launcher API potentially vulnerable to arbitrary code execution by an attacker with access to any user account on the local machine. It does not affect apps run by spark-submit or spark-shell. The attacker would be able to execute code as the user that ran the Spark application. Users are encouraged to update to version 2.1.2, 2.2.0 or later.
O3 Security · Impact-Aware SCA

Is GHSA-8rhc-48pp-52gr in your dependencies?

Find it across Maven, PyPI, including transitive dependencies.

Apache Spark Deserialization of Untrusted Data…